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Download

Click here to download the latest SFCC cartridge zip.

Installation

Narvar SFCC cartridge is SFRA compliant.

Link Narvar Cartridge

e Go to Administration > Sites > Manage Sites, click a site name and navigate to Settings tab.
e Add int_narvar_sfra in the Cartridges column as in the screenshot below.

Administration > Sites > Manage Sites > RefArch - Settings

General | | Settings = Cache  Site Status  Page Meta Tag Rules

cl
Click Apply to save the details. Click Reset o revert to the last saved state.

Instance Type: | Sandbox/Development %

Deprecated. The preferred way of configuring HTTP and HTTPS h es is by using new features of the site aliases configuration ("SEO > Aliases Configuration"). The HTTP/HTTPS hostname values set in this section will be used if no hostnames are defined by aliases
configuration and ay ded only to support an older configurat

HTTP Hostname:

HTTPS Hostname:

Instance Type: All
Cartridges: app_storefront_base:modules:int_narvar_sfra
Effective Cartridge Path: int_narvar:int_narvar_ s L les:int_narvar_sfra:plugin_apple_pay:plugin_f in_pinterest_ in_web_p: =

Apply  Reset

Import Metadata

Note: All xml files will be available under the Metadata folder in the downloaded cartridge.

Metadata.xml

e Go to Administration > Site Development > Import & Export.

e Upload system-objecttype-extensions.xml inside the Import & Export Files section.

e Then import system-objecttype-extensions.xml under the Metadata > Import section.

e On clicking Next a page shown below will appear. Click on the Import button to finish the process.

Validation Status

Current Action Finished XML schema validation.
o
o

Import File Content

System Type Extensions 3
1
°
o
a
o

Custom Preference Definitions 0

Import Options

Delete existing attribute definitions and attribute groups not contained in the import file, including attribute marked as

<= Provious


http://www.narvar.com
https://narvar-magento.s3-us-west-2.amazonaws.com/magento-extension/narvar-sfcc-release.zip

@ norvar

www.narvar.com

Jobs.xml

e Go to Administration > Operations > Import & Export.

e Upload jobs.xml inside Import & Export Files.
e Import jobs.xml under Jobs section by selecting REPLACE mode as shown below.

Administration > Operations > |mport & Export > Jobs Import Ste 1 - Select File > Step 2 - Validate File > Step 3 - Import

Jobs Import - Start Import

Step 30f 3.

Select an import mode and start the import by clicking Import.

Import Mode

O REPLACE Deletes and recreates existing database objects. Also creates new objects based on XML file.
DELETE  Deletes all database objects contained in the XML file

<< Previous

Impert ~ Cancel

Services.xml

e Go to Administration > Operations > Import & Export and upload services.xml.

e Import services.xml under Services section by selecting MERGE mode as shown below.

Administration > Operations > Import & Export > Service Import Step 1 - Select File > Service Import Step 2 - Validate File > Service Import Step 3 - Import

Service Import - Import

Stepdof &

Select an import mede and start the import by clicking Import.

O MERGE  Updates existing database objects and creates new onas based on XML file.
UPDATE  Updates existing database objects only (i.2., doesn't create new ones based on XML file).
REPLACE Deletes and recreates existing database abjects. Also creates new objects based on XML file.
DELETE  Deletes all database objects contained in the XML file.

<< Previous

Import ~ Cancel
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e Go to Administrations > Operations > Jobs. Here we have 2 jobs - NarvarOrderAPI and
NarvarUploadOrderFile.

e Click on a particular Job ID link, then click on the Job Steps tab and then click on the Scope as
shown below to select a scope.

Administration / Operations / Jobs

NarvarOrderAPI © m

General  Schedule and History ~ Resources  Job Steps  Failure Handling  Notification

Job Parameters n
D+ o
create x
Select Scope »
(+]
Scope @
Specific Sites v +
D Name Status
v RefArch RefArch online
RefArchGlobal RefArchGlobal online
SiteGenesis SiteGenesis online
isGlobal SiteGenesisGlobal online
smSite smsite online

Note: Narvar strongly recommends having different jobs for different sites.
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Services

e Go to Administrations > Operations > Services. We have sections as below.
Services:
o NARVAR_BULK_INGESTION
o NARVAR_LOG_INGESTION
o NARVAR_ORDER_INGESTION
Profiles:
o NARVAR
Credentials:
o NARVAR_BULK_API_CREDS
o NARVAR_LOGS APl _CREDS
o NARVAR_API_CREDS
e Service’s and credential’'s names should be suffixed with “_<site-id>" as shown below.

Administration > Operations > Services

Services = Profiles  Credentials

Services®
Select Al  Name Type Profile  Credentials Status
NARVAR BULK INGESTION RefArch GENERIC NARVAR NARVAR BULK API CREDS RefArch Live
NARVAR BULK INGESTION RefArchGlobal HTTP NARVAR NARVAR BULK API CREDS RefArchGlobal Live
NARVAR LOG INGESTION RefArch HTTP NARVAR NARVAR LOGS API CREDS RefArch Live
NARVAR LOG INGESTION RefArchGlobal HTTP NARVAR NARVAR LOGS API CREDS RefArchGlobal Live
- NARVAR ORDER INGESTION RefArch HTTP NARVAR NARVAR APl CREDS RefArch Live
NARVAR ORDER INGESTION RefArchGlobal HTTP NARVAR NARVAR APl CREDS RefArchGlobal Live

e To add or update Credentials, click on the Credentials link and enter URL, User and Password as
shown below.

Note : Ensure that the credentials are set for all the 3 Services accordingly.

Administration > Operations > Services > NARVAR_BULK_API_CREDS_RefArch - Details

NARVAR_BULK_API_CREDS_RefArch

Fields with a red asterisk (*) are mandatory. Click Apply to save the details. Click Reset to revert to the last saved state.

These credentials are used by 1 service.

Name:*  NARVAR_BULK_API_CREDS_RefArch
URL:  https://raavi-stO1.narvar.qa/api/vi1/sfcc/order/bulk
User:  sfcctest

Password: |seeseese

Apply  Reset
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URLs no
Staging:

e NARVAR_BULK_API_CREDS: https://raavi-st01.narvar. i/v1/sf

e NARVAR_API_CREDS: h ://raavi-st01.narvar. i/vl/sf rder

e NARVAR_LOGS_API_CREDS: h : mmerce-| r-st0l.narvar. i/vl/l
Production:

e NARVAR_BULK_API_CREDS: https://raavi.narvar.com/api/vl/sfcc/order/bulk
e NARVAR_API_CREDS: https://raavi.narvar.com/api/vl/sfcc/order
e NARVAR_LOGS_API_CREDS: https://commerce-logger.narvar.com/api/vl/logs

Note: User and Password fields will be shared by the Narvar team. For different sites, ensure that the
respective credentials are configured. To know more about these fields please refer to this documentation

Site Preferences

e Go to Merchant Tools > Site Preferences > Custom Preferences > Narvar.
e By default, Enable/Disable Info Logs to send to Narvar is set to false.To debug any issues
and send logs to Narvar for investigation set the flag as true.

Merchant Tools / Site Preferences / Custom Site Preference Groups /

) [ Cancel [ Apply to Other Sites Save
Narvar
Instance Type
Sandbox v
[a]~
1-4 v of4
Name Value Default Value

Yes v

Enable/Disable Narvar APIs Yes Edit Across Sites
Enable/Disable Narvar APIs. This will turn on/off all API calls, inclu...
Yes +

Enable/Disable bulk upload to Narvar Yes Edit Across Sites
Enable/Disable bulk upload to Narvar. This will turn on/off bulk upl...
. Yes B

Enable/Disable Info Logs to send to Narvar No Edit Across Sites
Enable/Disable Info Logs to send to Narvar. This will turn on/off all...

Narvar Failed Attempts Before Batch 3 3 Edit Across Sites

Verify Installation

e Go to Administrations > Operations > Jobs and run NarvarOrderAPI job.

e Verify job logs if there is any issue. If no issues are found then the cartridge has been installed
successfully.

e Now orders can be placed and jobs can be triggered to send orders to Narvar.

Shipping Methods

e Go to Merchant Tools > Ordering > Shipping Methods
e To add Narvar Carrier Code and Narvar Service Code for a particular Shipping method, click on
the ID link and then add the Carrier and Service code.
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Merchant Tools > Ordering > Shipping_Methods > 001

Select Language: English (United States) s

General

Use the fields below to change the name and description of the shipping method as they should appear in the Storefront.

If the cost of this shipping method is based o

e cost defined by another shipping method, select the base shipping method. Note: The shipping calculation process only considers a dependency of one le

vel
Select an appropriate tax class for the shipping method. Fields with a red asterisk (") a

re mandatory.

D
© Name:
© Description:

Enabled:
Default:
Based On: * | -None-

Tax Class: | Standard

o o o

Currency: | US Dollar (USD)
Store Pick Up
Store Pickup Enabled:*
Shipping Method Attributes
© Estimated Arrival Time:
Narvar
Narvar Carrier Code: |ups

Narvar Service Code: €2

Note: Values for Narvar Carrier Code and Narvar Service Code will be provided by the Narvar team.

Populate Shipment’s shipped from attribute

To populate the shipment’s shipped_from attribute, one must include a store id to a particular
shipment. To do so

e Go to Merchant Tools > Ordering > Orders
e Click an order, click on the Shipment section add the Pickup Store ID under Attributes tab.

Merchant Tools > Ordering > Orders > Order: 00030901(RefArch) > Shipment: 00149001

General  Attributes

On this page you can edit the attributes of the shipment. Fields with a red asterisk (') are mandatory. Click Apply to save changes. Click Reset to revert your changes.

Store Pickup Information
Pickup Store ID: | 101

Store Pickup Message:

Apply  Reset

Note: To get the store id, go to Merchant Tools > Online Marketing > Stores and pick the ID.

Customizing Cartridge

Many retailers use demandware as a storefront configurator and end up using different OMS for managing
orders, fulfilments etc . Retailers can customize Order API related data like Shipments, Order Iltems etc.

For example, modifying shipment details.
e To modify shipment details, go to

<Project_directory>/int_narvar_sfra/cartridge/scripts/transformer/shipmentsDetails/custom.js.
Refer below screenshot

e (o to getCustomizedShipmentDetails function for any custom modifications.
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o This function can be modified with any custom codes as per the retailer’s need. Retailers
can make api calls to get shipment information also.

The shipment object should look like the contract present inside the custom.js file.

custom.js file will be called inside

<Project_directory>/int_narvar_sfra/cartridge/scripts/transformer/shipmentsDetails/index.js.

e index.js file contains the base transformation for the shipments details.

Note: Above steps are for custom configuration. For those not using custom configuration , base
transformation is used and it works only for those using Demandware as OMS.
Path - <Project_directory>/int_narvar_sfra/cartridge/scripts/transformer/shipmentsDetails/index.js

[ custom.js <

cartridges > int_narvar_sfra > cartridge > scripts > transformer > shipmentsDetails > [ custom.js > ...

SebashishM, a day ago | 1 author (SebashishM)

1 /* eslint—disable no—unused-vars x/

2 'use strict';

3 // Shipment details

4 /*

5 “"shipments": [

6 {

7 "ship_method": "Narwvar Concierge",

8 “"carrier_service": "E1", // This is must required

9 "items_info"™: [

10 1{

11 "quantity": 4,

12 "sku'": "758518548197M",

13 "item_id": ""75@518548197M"

14 H

15 1.

16 “carrier": "C1", // This is must required

17 “"shipped_to": {

18 “first_name": '"Sebashish",

19 "last_name'": "Meher',
20 “phone": "5697798936",
21 "email": "test@gmail.com",
22 “fax": ""
23 "address": {
24 “"street_1": "#509, 9th A main",
25 “"street_2": "BEML layout, Thubarahalli",
26 ""city'": "Bangalore',
27 ""'state'": "CA'",
28 "zip": "959e1",
29 “"country"™: ''us',
30 "lat": @,
31 “"lng": ©
32 ¥
33 ¥,
34 // ship_source : 'DC—West', // Not mandatory but highly recommended for Returns
35 // shipped_from: {}, // Not mandatory but highly recommended for Returns & EDD
36 "ship_discount": @,
37 "ship_total"™: @,
38 “"ship_tax": @,
39 "ship_date": "2020-03-17T14:36:07Z",
40 "tracking_number": "trkl123", // Must required field
41 }

42 1

43 *)/

44 Sk

45 * This is a description of the getCustomizedShipmentsDetails function.
46 * This function is used to get customize shipments details

47 * @param {Object} shipmentList — This is the initial array of shipments
48 * @param {dw.order.Order} order — This is the demandware order

49 * @returns {Array} — shipmentList: This will return customized shipmentList
50 E 4

51 const getCustomizedShipmentsDetails = function (shipmentList, order) {
52 return shipmentList;

53 L

54
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Narvar Apple Wallet Integration

Narvar enables retailers to enable Apple Wallet on their B2C checkout flows. This integration works by
implementing b2c apple pay hook

How to enable integration

Existing Apple pay hook

If the apple pay hook is already implemented by other cartridges for your storefront, then follow the below
guide

https: . le.com ment/d/1awsRaxpXbXDbZDPfz_cH4AHRVMgZAOMR4_v_vMG4VdA

Non-existing Apple pay hook
If the apple pay hook is not implemented in any other cartridges, then the below steps can be followed.

Configure Service

e Go to Administrations > Operations > Services.
e Find out NARVAR _APPLEPAY ORDER _DETAILS service and edit that by appending “_<site-id>"
as shown below.

Administration > Operations > Services

Services | Profiles  Credentials

. )
Services

Select All Name Type Profile  Credentials Status
a NARVAR APPLEPAY ORDER DETAILS RefArch HTTP. NARVAR NARVAR APPLEPAY API CREDS RefArch Live

e Also update the credential called NARVAR_APPLEPAY _API_CREDS by appending “_<site-id>"
and update URL, User and Password as shown below.

Administration > Operations > Services > NARVAR_APPLEPAY_API_CREDS_RefArch - Details

NARVAR_APPLEPAY_API_CREDS_RefArch

ory. Click Apply to save the details. Click Reset to revert to the last saved state.

Name:* NARVAR_APPLEPAY_API_CREDS_RefArch

URL: | https://ws.narvar.qa/api/vi/orders/apple-wallet

User: (12312e00qwe123 )

Password: | +esees

10
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URLs
QA: https://ws.narvar.qa/api/v1/orders/apple-wallet

PROD: https://ws.narvar.com/api/v1/orders/apple-wallet

User and Password must be provided by the Narvar team. For different sites, ensure that the
respective credentials are configured. To know more about these fields please refer to this
documentation

How to disable integration

- Search for hooks.json present inside int_narvar_sfra
- Replace that file contents with the below JSON and re-upload the cartridge.

"hooks": []

To learn more about Narvar Apple wallet integration please follow this document:

https://docs.google.com/document/d/1awsRaxpXbXDbZDPfz cH4AHRVMaZAOMR4 v _vMG4VdA

Also, follow this document to find out how to integrate with the hook:

https://docs.google.com/document/d/104TGS4NXpLILrlyEceb6YU-2psR4-N5Y-ypxiGlfc4w

11
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